Home | SBAdmin Support | Knowledge Base | Why can I not install SBAdmin software on 64-bit Linux system?

SBAdmin Support

Need Help? We got you covered.

Why can I not install SBAdmin software on 64-bit Linux system?

Why can I not install SBAdmin software on 64-bit Linux system?

I received an error trying to install Storix SBA on my 64-bit linux system. The error is

This software requires the ncurses library (version 4 or 5), which
is not installed on this system. You must install ncurses from your
Linux distribution media before installing this software.

I have ncurses installed in /usr/lib64/libncurses.so.5


ANSWER



Most 64-bit systems have libraries installed for both 32 and 64-bit binaries. This is for compatibility for legacy applications that have not been recompiled for 64-bit. (Since most applications do not take advantage of the additional memory space). Some Linux distributions do not install these additional Legacy libraries by default. Below is a link that describes the issue. (It refers to zSeries, but is valid for other system architectures).

http://www-128.ibm.com/developerworks/eserver/library/es-rhel-coexist/

For now, Storix recommends that you install the additional library sets because you may experience additional errors with other 3rd party applications until most systems are 64-bit.

Below is a link to a FAQ on Redhat's website that will describe how to install the 32-bit libraries.

http://kbase.redhat.com/faq/FAQ_58_7581.shtm